DBeaver CLIENT_PLUGIN_AUTH is required 해결법

DBeaver뿐만 아니라 다른 클라이언트 프로그램, 서비스에서 mysql db 접속을 시도할 때 CLIENT_PLUGIN_AUTH is required 라는 에러가 뜨면서 안되는 경우는 사용중인 mysql-connector가 구버전일 때 발생할 수 있습니다.

 

특히 DB접속 클라이언트 프로그램에서 자동으로 드라이버를 설치해주는 경우에 버전이 안맞는 경우가 있기에

 

CLIENT_PLUGIN_AUTH is required 해결하기

드라이버 라이브러리 변경을 위해 Edit Driver Settings에 들어갑니다.

 

 

 

기존에 있던 mysql-connector는 Delete를 눌러 삭제해줍니다.

 

 

 

Add File로 사용중인 mysql 버전을 호환하는 connector를 추가합니다. 그리고 Class Name도 맞게 같이 바꿔줘야 합니다.

 

 

 

적용 후 테스트하면 정상적으로 되는 것을 확인할 수 있습니다.

 

댓글(0)

Designed by JB FACTORY